Résoudre les problèmes de lancement XAMPP

Toutes les questions et les suggestions sur l'installation et le fonctionnement du logiciel "Elever mes Oiseaux"
Avatar du membre
jose29
Administrateur du site
Administrateur du site
Messages : 1999
Enregistré le : 23 déc. 2009, 21:49
Votre LOCALISATION : PLEYBEN
LOCALISATION : Finistère, BRETAGNE, FRANCE
Vos OISEAUX : YOUYOUS DU SENEGAL
Vos OISEAUX(2) : PETITS EXOTIQUES
Vos OISEAUX(3) : VOLAILLES
Précisions sur vos OISEAUX : PADDAS, DIAMANTS de GOULD, MOINEAUX du JAPON, FAISANS DORES, POULES
Contact :
Bretagne

Résoudre les problèmes de lancement XAMPP

Message par jose29 » 03 mars 2018, 09:55

Bonjour,
Xampp devrait causer moins de soucis d'installation que wamp sur la plupart des ordinateurs.
Cependant, certaines remontées de la part d'utilisateurs signalent l'impossibilité de lancer le service Apache après l'installation.
En bas du panneau de contrôle de xampp, un message de ce type s'affiche et le pavé Apache reste jaune :
Status change detected: stopped
15:33:26  [Apache]      Error: Apache shutdown unexpectedly.
15:33:26  [Apache]      This may be due to a blocked port, missing dependencies,
15:33:26  [Apache]      improper privileges, a crash, or a shutdown by another method.
15:33:26  [Apache]      Press the Logs button to view error logs and check
15:33:26  [Apache]      the Windows Event Viewer for more clues
15:33:26  [Apache]      If you need more help, copy and post this
15:33:26  [Apache]      entire log window on the forums
Cela veut dire que le port 80 utilisé par Xampp est déjà utilisé par une autre application : la plus connue est Skype.
Je propose 3 solutions (au choix):
1 - désactiver Skype, lorsqu'on utilise xampp pour Elever mes Oiseaux. Problème, il faudra penser à le réactiver ensuite.
2 - changer le port utilisé par Skype : pour cela, aller dans Skype - Outils - Options - Avancé - Connexion
Dans la fenêtre ouverte, décoché la cadre devant "Utilser les ports 80 et 443 ...." - Sauvegarder et redémarrer Skype.
3 - changer le port 80 pour xampp :
Dans le panneau de contrôle de xampp, à droite de la ligne Apache, cliquer sur "Config", puis sur "Apache(httpd.conf)"
Cela ouvre un fichier texte dans le bloc-notes de windows. Descendre quelques lignes pour trouver la ligne "Listen 80". Sur cette ligne changer, par exemple le 80 en 8080. Sauvegarder en faisant Edition - Enregistrer.
Fermer le panneau de contrôle de xampp et ouvrer-le à nouveau, ça devrait suffire..

Si après une de ces méthodes cela ne fonctionne pas, je vous conseille de copier et coller "Error: Apache shutdown unexpectedly" dans le cadre de recherche de Google pour ouvrir une page où plusieurs autres solutions sont développées dans divers forums.
Kénavo

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité